带你撸出一手好代码
intellij idea中常规项目转为maven项目后编译报错解决

intellij idea中, 普通项目通过右击项目, add frameworks support菜单功能项中的maven选项转换为maven项目后, 假如项目使用的java 1.8会出现编译错误


Error:(56, 50) java: -source 1.5 中不支持 diamond 运算符

  (请使用 -source 7 或更高版本以启用 diamond 运算符)


要解决这个错误, 需要在 project  structure  下 modules 选项的sources面板中将 language level改成1.8


同时,还要在,setting 下 java compiler 选项中将项目的 target bytecode version也改成1.8


否则会出现 


Error:java: Compilation failed: internal java compiler error


错误


作者:陈大侠
日期:2018-04-18

留言(0条)

我要发表留言

您的大名 选填
电子邮箱 选填

欢迎关注微信公众号 「带你撸出一手好代码」

首页    GitHub 知乎 豆瓣 博客园